Installing the Arduino Libraries for the Sparrow Nodes

  • Step 1. Open the Arduino IDE
  • Step 2. Go to File → Preferences
  • Step 3. In the Additional Boards Manager URLs textbox add the following link:
  • Step 4. Close the window by pressing OK
  • Step 5. Go to Tools → Board → Boards Manager
  • Step 6. Search “sparrow”
  • Step 7. Hit Install
  • Step 8. You're done!

Here is a video tutorial of the process:

If this method doesn't work, here is the manual version

If this method doesn't work, here is the manual version

  1. Download Arduino
  2. Download and unzip the patch in a separate folder
  3. Locate the installation folder of Arduino on your drive (for Windows it's usually Program Files)
  4. Copy in Arduino\hardware\arduino\cores the contents of the folder sparrow_patch\Arduino\hardware\arduino\cores\sparrow
  5. Replace the file Arduino\hardware\arduino\boards.txt with sparrow_patch\Arduino\hardware\arduino\boards.txt
  6. Copy in Arduino\hardware\arduino\variants the folder named sparrow from sparrow_patch\Arduino\hardware\arduino\variants
  7. Restart the Arduino IDE

After a successful patch, you should be able to select a new board named Sparrow from the Tools>Board menu. Connect the Sparrow Nest board through the supplied micro-USB cable to your computer and select the appropriate COM port from the Tools>Port menu

You're all set up!

Excited to run your first code on Sparrow? Check out how to say Hello World!